トップ 最新 翌月»

たいぷらいたーざっき。

2010|09|10|11|12|
2011|01|02|03|04|05|06|07|08|09|10|11|12|
2012|01|02|03|04|05|06|09|

2010-09-26 ファーストコンタクト

_ [雑記] ファーストコンタクト

 ブログ,はじめました.

 甲子園球場の近くに住んでいるけれども,野球にはちっとも興味がないB3の人です.同じハンドル(タイプライター)でニコニコ動画に動画が上がっているとかいないとかしますが,そっとしておいてやってください.

 そんなこんなで気ままに書いていこうと思います.

_ [雑記] って,

tDiaryじゃないですかー! 3.x系列出てるとは.

gray2のテーマ,サイドバーに対応してないのかな? あとでよく見てみるかな.


2010-09-28 Ruby on Rails on Ubuntu 10.04(Lucid Lynx)

_ [Ruby][Rails][Linux][卒研ゼミ] Ruby on Rails on Ubuntu 10.04(Lucid Lynx)

 2日前くらいにUbuntu 10.04にRuby on Railsをインストールしたので,コマンドの履歴が残ってるうちにメモっておこうと思います.
// さっくりとRuby, irb, librubyあたりをインストール.
$ sudo apt-get install ruby irb libruby
 
// RubyGemsもインストール.PerlのPPMみたいなもんですよね? きっと.
$ sudo apt-get install rubygems
 
// rubygemsが呼べるか確認しておきます.
$ rubygems
rubygems: command not found
 
// ああ,gemでした.
$ gem
(省略)
 
// さくさくとSQLite3をつっこみます.
$ sudo apt-get install sqlite3 sqlite3-dev
 
// sqlite3-rubyをいれませう
$ sudo gem install sqlite3-ruby
ERROR:  Error installing sqlite3-ruby:
        ERROR: Failed to build gem native extension.
 
// えー… 
// …こういうときはUbuntuでパッケージが用意されてたりすることが!
$ apt-cache search sqlite3 ruby
libsqlite3-ruby - SQLite3 interface for Ruby
 
// 便利なのかなんなのかよくわからんけどインストール.
$ sudo apt-get install libsqlite3-ruby
 
// このへんで ruby1.8-dev パッケージもいれた記録が残ってるんだけど,
// 結局必要だったのかどうかは "?"
 
// suzukiが先輩に聞いた話によると,あんまり新しいRailsはちょっと困るらしい.
// ので,2.3.8とバージョンを指定してインストール.
$ sudo gem install rails --version 2.3.8
 
// かなり時間がかかるのでティータイム.
 
// ぐーれいとぅ!
$ rails
rails: command not found
 
// (12/25追記) お恥ずかしい… パス通さなきゃでした.
$ vim ~/.bashrc
 export PATH=/var/lib/gems/1.8/bin:$PATH
 
$ source ~/.bashrc (またはシェル再立ち上げ)
 
// ぐーれいとぅ!
$ rails
すごくすごくすごくすごーく役に立ちました.

トップ 最新 翌月»

operated by Kindai ECL

operated by Kindai ECL